Installing macOS High Sierra on Proxmox 5

With the final release of Mojave, this tutorial is now out of date, see the new tutorial for installing Mojave instead!

This tutorial for installing macOS Sierra has been adapted for Proxmox 5 from Kholia’s GitHub project for installing into vanilla KVM. There is more documentation there which will help out with enabling extra features and diagnosing problems!

Requirements

I’ll assume you already have Proxmox 5.1 installed. You also need a real Mac available in order to download High Sierra from the App Store and build the installation ISO. Your Proxmox host computer must have an Intel CPU at least as new as Penryn (I believe you would need a a custom Mac kernel in order to use an AMD CPU).

First step: Create an installation ISO

On a Mac machine, download the macOS High Sierra installer from the App Store (this will download it into your Applications folder).

Check the size of the completed download. Some people will end up with a 16MB installer, and some will receive the full 5GB installer (nobody knows why yet). If you received the 16MB version, follow the instructions here to get the full 5GB version instead.

Now run this script in order to create HighSierra.iso from the installer. The ISO should get saved to your desktop. Upload the ISO to your Proxmox server’s ISO store (typically /var/lib/vz/template/iso).

Prepare a Clover image

We’ll be using Clover as a bootloader for High Sierra.

Download this Clover disk image (that I built using kholia’s build script from Clover r4428), unpack it, and upload it to Proxmox’s ISO store at /var/lib/vz/template/iso. Although it has a .iso file extension, this is actually a hard disk image. (I do it this way because Proxmox has nicer tools for storing and picking .iso files for us)

Fetch the OSK authentication key

macOS checks that it is running on real Mac hardware, and refuses to boot on third-party hardware. You can get around this by reading an authentication key out of your real Mac hardware (the OSK key). Run the first bit of C code from this page (you’ll need XCode installed) and it’ll print out the 64 character OSK for you. Make a note of it.

Every Mac uses the same OSK, so don’t be surprised if it doesn’t look like a random string!

Create the VM

From the Proxmox web UI, create a new virtual machine as shown below.

In the Options page for the VM, make sure “use tablet for pointer” is set to “Yes”. Change “BIOS” to “OVMF (UEFI)”.

In the Hardware page for the VM, change the the Display to Standard VGA (std). Add a second DVD drive at IDE0, set it to use your HighSierra.iso. Add an “EFI Disk” too.

Don’t try to start the VM just yet. First, SSH into your Proxmox server so we can make some edits to the configuration files.

Edit /etc/pve/qemu-server/YOUR-VM-ID-HERE.conf (with nano or vim). Add these two lines, being sure to subtitute the OSK you extracted earlier into the right place:

machine: pc-q35-2.11
args: -device isa-applesmc,osk="THE-OSK-YOU-EXTRACTED-GOES-HERE" -smbios type=2 -cpu Penryn,kvm=on,vendor=GenuineIntel,+invtsc,vmware-cpuid-freq=on

Find the two lines that define the CDROM drives (ide0 and ide2), and remove the “,media=cdrom” part from both lines. Add “,cache=unsafe” in its place. If the Sierra boot option doesn’t appear in Clover later, try adding “,media=cdrom” back to the line for the Sierra ISO.

On the net0 line, change “e1000” to “e1000-82545em”. This variant is supported by OS X.

Return to the Options tab and change the boot order to put IDE2 (the Clover image) first.

Configure Proxmox

On Proxmox, run “echo 1 > /sys/module/kvm/parameters/ignore_msrs” to avoid a bootloop during macOS boot. To make this change persist across Proxmox reboots, run:

echo "options kvm ignore_msrs=Y" >>/etc/modprobe.d/kvm.conf && update-initramfs -k all -u

You must now install a patched version of Proxmox’s OVMF library in order to be able to boot High Sierra.

Install High Sierra

Now start up your VM.

Go to the Console tab, quickly hit Escape at the Proxmox logo to enter the OVMF configuration. If your keyboard doesn’t work, leave the Console tab, stop the VM, start the VM, then re-enter the console tab. If pressing escape still doesn’t enter the menu, make sure you are using “machine: pc-q35-2.11” in your VM config and you do not have a USB keyboard defined in pve-q35.cfg (it seems that the OVMF menu only supports the default PS/2 keyboard).

Follow the steps above to set the screen resolution to 1024×768 and “reset” to apply the new settings (not “continue”). This step is required to avoid scrambled graphics (Clover resolution must match OVMF resolution).

High Sierra doesn’t support QEMU’s PS2 keyboard and mouse, but it does support the USB tablet we’ve selected on the Options page (thanks to Jack H for the tip about the tablet!) Edit /usr/share/qemu-server/pve-q35.cfg and add a USB keyboard to the bottom of the file to replace the PS/2 one it would provide by default:

[device "keyboard1"]
 driver = "usb-kbd"
 bus = "ehci.0"
 port = "2"

(Port 1 is occupied by the USB tablet that Proxmox will provide for us)

We’ve added this to the config file instead of to the VM’s args directly. If we were to add it to the VM’s args, then when Proxmox constructs its call to KVM to launch the VM, the device definition would appear before the pve-q35.cfg file is included, which defines the USB busses. However, the device definition must appear after the definition of the USB bus that it refers to.

Note that this file is whitespace-sensitive, make you you don’t add any blank lines that have extraneous spaces on them.

Stop the VM and start it again to pick up this new keyboard config. It should now boot into Clover.

Clover boot screen

On Proxmox 5.2, there’s currently a problem where the resolution you chose in the UEFI menu doesn’t actually get applied when you initially boot to Clover, which will cause booting macOS to fail (scrambled progress bar followed by a hang). You can fix this by hitting Reset on your VM when you reach the Clover screen (not shutdown/start), and come back to Clover. After the reset, the resolution will be applied correctly. You’ll have to do this each time you Start the VM.

Press enter to boot the “Boot OS X Install from Install macOS High Sierra” entry and the installer should appear. Choose your language.

Our virtual hard drive needs to be erased/formatted before we can install to it, so select the Disk Utility option. Follow the steps below to format the disk:

Now we’re ready to begin installation!

After the first stage of installation, the VM should reboot itself and continue installation by booting from the hard drive. Answer the initial install questions, and you’ll be logged on! (Note that you’ll probably want to hold off on logging into your iCloud account until you’ve configured your SMBIOS to your liking in Clover Configurator)

Make the Clover install permanent

We’re currently booting using Clover from the attached CD image. Let’s install that to the hard drive instead. Pop open Terminal and run “diskutil list” to see what drives we have available.

Use “sudo dd if=source of=dest” to copy the EFI partition from the Clover CD and overwrite the EFI partition on the hard disk. The Clover CD is the one with the “linux filesystem” on it, and the main hard disk is the one with the large Apple_APFS container partition on it.

In my case these EFI partitions ended up being called disk0s1 and disk2s1 respectively, so I ran “sudo dd if=/dev/disk0s1 of=/dev/disk2s1” (N.B. if you get these names wrong, you will erase the wrong disk and you’ll have to start the installation over again!).

Now shut down the VM, and remove both the Clover and the Sierra CDROM drives from the Hardware tab. On the Options tab, edit the boot order to place SATA0 as the first disk. Boot up. If everything went well, you should see a Clover boot menu, and you can select “boot macOS from *disk*” to boot High Sierra.

Sleep management

I found that I was unable to wake High Sierra from sleep using my mouse or keyboard. You can either disable system sleep in High Sierra’s Energy Saver settings to avoid this, or you can manually wake the VM up from sleep from Proxmox by running:

qm monitor YOUR-VM-ID-HERE
system_wakeup
quit

Editing your Clover/EFI settings

You can use the Clover Configurator tool to edit your Clover configuration, which is stored in the hard drive’s EFI partition. This tool should mount the EFI partition for you. If you want to mount it without using Clover Configurator, first check the device name of the EFI partition in the terminal:

~$ diskutil list
/dev/disk0 (external):
   #:             TYPE   NAME           SIZE       IDENTIFIER
   0: GUID_partition_scheme             512.1 GB   disk0
   1:              EFI   EFI            209.7 MB   disk0s1
   2:        Apple_HFS   Main           511.8 GB   disk0s2

Then you can mount it like so:

sudo mkdir /Volumes/EFI
sudo mount -t msdos /dev/disk0s1 /Volumes/EFI

Passing through advanced CPU features

You can pass through CPU features like AVX and AES-NI for increased guest performance, see here for details.

USB passthrough

Since I want to use this as my primary computer, I want to use a USB keyboard and mouse plugged directly into Proxmox, rather than sending my input through the web VNC console.

Proxmox has good documentation for USB passthrough. Basically, run “qm monitor YOUR-VM-ID-HERE”, then “info usbhost” to get a list of the USB devices connected to Proxmox:

qm> info usbhost
 Bus 3, Addr 12, Port 6, Speed 480 Mb/s
 Class 00: USB device 8564:1000, Mass Storage Device
 Bus 3, Addr 11, Port 5.4, Speed 12 Mb/s
 Class 00: USB device 04d9:0141, USB Keyboard
 Bus 3, Addr 10, Port 5.1.2, Speed 12 Mb/s
 Class 00: USB device 046d:c52b, USB Receiver
 Bus 3, Addr 9, Port 14.4, Speed 12 Mb/s
 Class 00: USB device 046d:c227, G15 GamePanel LCD
 Bus 3, Addr 8, Port 14.1, Speed 1.5 Mb/s
 Class 00: USB device 046d:c226, G15 Gaming Keyboard
 Bus 3, Addr 6, Port 11, Speed 12 Mb/s
 Class e0: USB device 0b05:17d0,
 Bus 3, Addr 2, Port 1, Speed 1.5 Mb/s
 Class 00: USB device 068e:00f2, CH PRO PEDALS USB

In this case I can add my keyboard and mouse to USB passthrough by quitting qm, then running:

qm set YOUR-VM-ID-HERE -usb1 host=04d9:0141
qm set YOUR-VM-ID-HERE -usb2 host=046d:c52b

This saves the devices to the VM configuration for you. It’s possible to hot-add USB devices, but I just rebooted my VM to have the new settings apply.

You can also pass through USB devices by passing through an entire USB controller using Proxmox’s PCIe passthrough feature.

PCIe GPU passthrough

For near-native graphics performance you can pass through a video card. There are details in the Proxmox manual. You should also check out Hackintosh tutorials for more details on installing the drivers correctly (and configuring Clover correctly) for the card you want to install.

If you don’t want to pass through a video card, but want to bump the screen resolution up to 1920×1080, use Clover Configurator to set Clover’s screen resolution to match that, then enter the OVMF settings at boot time by pressing escape, and set the new resolution there as well.

My Mojave installation

I’ve described my host hardware and the Proxmox and VM configuration for the Mojave VM I use daily in this post, including my PCIe passthrough configuration.

228 thoughts on “Installing macOS High Sierra on Proxmox 5”

  1. Just an update to last post, upgraded to 5.2 and machine seems to boot fine. However, I have no keyboard from the console now. I can still remote into the machine however and that works fine which is how it is accessed most of the time. Have not had any time to dig as to why keyboard not working.

    1. Thanks for the test! Most likely your /usr/share/qemu-server/pve-q35.cfg file got overwritten by the upgrade and the definition of the USB keyboard was lost, you’ll need to readd it.

      1. as PRoxmox updates get released rather quickly and the file /usr/share/qemu-server/pve-q35.cfg gets overwritten frequently i looked for a permanent solution without interfering with other machines.

        So here it is:
        1) leave the file /usr/share/qemu-server/pve-q35.cfg as it is, do not change it.
        2) create a new file /usr/share/qemu-server/pve-q35-macos.cfg with the following content:

        [device “ehci-3”]
        driver = “ich9-usb-ehci1”
        multifunction = “on”
        bus = “pcie.0”
        addr = “1d.3”

        [device “keyboard1”]
        driver = “usb-kbd”
        bus = “ehci-3.0”
        port = “2”

        This will add a new usb-controller and then the keyboard being attached to that otherwise unused controller (i set it to be non conflicting with other controllers used by the standard q35-machine)

        3) we need to instruct proxmox to include this file by changing the args line in /etc/pve/qemu-server/YOUR-VM-ID-HERE.conf

        args: -device isa-applesmc,osk=”STATIC-OSK-KEY-HERE” -smbios type=2 -cpu Penryn,kvm=on,vendor=GenuineIntel,+invtsc,vmware-cpuid-freq=on -readconfig /usr/share/qemu-server/pve-q35-macos.cfg

        with this change, KVM will load pve-q35-macos.cfg first, which will attach a new usb-controller, then an usb-keyboard and finally everthing (standard-config) of pve-q35.cfg.

        BAM – update safe!

      2. Follow Up to my Post about sourcing out the keyboard config in pve-q35.cfg, i found a way to make the UEFI (OVMF) update resistant without interfering with other machines:

        1) your MacOS should already be installed and running
        2) shutdown the VM
        3) create the directory /usr/share/pve-edk2-firmware/macos/
        4) copy the working OVMF-Files (also found in the package pve-edk2-firmware_1.20180316-1_all.deb) to /usr/share/pve-edk2-firmware/macos/

        the contents of this new directory should look like this:

        ll /usr/share/pve-edk2-firmware/macos/
        total 2056
        drwxr-xr-x 2 root root 4096 Aug 26 10:49 .
        drwxr-xr-x 3 root root 4096 Aug 26 10:49 ..
        -rw-r–r– 1 root root 1966080 Aug 26 10:49 OVMF_CODE.fd
        -rw-r–r– 1 root root 131072 Aug 26 10:49 OVMF_VARS.fd

        5) within the “Options”-Tab of the VM change it back from “BIOS: OVMF (UEFI)” to “Default (SeaBIOS)”

        this step is needed, so the default OVMF is not loaded.

        6) add these two options for the “args”-parameter to your vm.conf located at /etc/pve/qemu-server/YOUR-VM-ID-HERE.conf

        -drive if=pflash,unit=0,format=raw,readonly,file=/usr/share/pve-edk2-firmware/macos/OVMF_CODE.fd -drive if=pflash,unit=1,format=qcow2,id=drive-efidisk0,file=/mnt/raid1/images/YOUR-VM-ID-HERE/vm-YOUR-VM-ID-HERE-disk-2.qcow2

        Especially take care to insert the correct path for your efidisk, otherwise the machine won’t boot.

        the final “args”-parameter will look like this (if you also applied my pve-q35 “patch”):

        args: -drive if=pflash,unit=0,format=raw,readonly,file=/usr/share/pve-edk2-firmware/macos/OVMF_CODE.fd -drive if=pflash,unit=1,format=qcow2,id=drive-efidisk0,file=/mnt/raid1/images/105/vm-105-disk-2.qcow2 -device isa-applesmc,osk=”PUT-STATIC-OSK-KEY-HERE” -smbios type=2 -cpu Penryn,kvm=on,vendor=GenuineIntel,+invtsc,vmware-cpuid-freq=on -readconfig /usr/share/qemu-server/pve-q35-macos.cfg

        There you have it! Update safe UEFI files!

  2. (web don’t show reply button)

    Yes, all of my reboots show 1024×768, is saved. But I when enable keybord section I can’t boot with correct resolution…

    thx!

  3. Hi Nick

    I am getting this error when i start VM
    kvm: -machine type=pc-q35-2.11: unsupported machine type

    when i remove pc-q35-2.11 it works and load clover but in clover there i am getting the option to go to shell not… will you please guide me what am i missing?

    1. Nick,

      I had the same issue until I upgraded Proxmox to the latest version.
      Run all the updates and the error should disappear.

  4. mclssk says:
    May 20, 2018 at 8:48 am
    (web don’t show reply button)

    Yes, all of my reboots show 1024×768, is saved. But I when enable keybord section I can’t boot with correct resolution…

    I am getting the same problem. 1024×768 shows saved but when I restart to enable the usb keyboard, but the resolution being used is 640. Please help!

    1. I have the same issue. This is very annoying and I am now stuck on the install. It’s either no keyboard or wrong resolution, neither of those circumventable at this time 🙁

  5. Working with 5.2. Thanks for the guide! Not sure what to do with the Configurator/SMBIOS though. Which chipset do I choose? The physical machine’s or the virtualized Penryn?

  6. Any update for Proxmox 5.2? I’m still stuck on the install facing the same issue where it’s either no keyboard or wrong resolution. Changing the resolution does work, and it saves 1024×768, but that resolution is only used when using the “reset” option in the OVMF menu. We obviously can’t do that without a keyboard, but then again we also need a keyboard to install macOS. Is there a way to force the resolution?

        1. I installed a fresh Proxmox 5.2-1 with the same graphic issues as described. As an experiment I tried machine: pc-q35-2.12 in the config and it seems like it worked… Still installing/testing.

          1. News in case you tried pc-q35-2.12: proxmox will interrupt start sequence as pc-q35-2.12 is not defined. Now try that: start with pc-q35-2.11 and while running change it to pc-q35-2.12 in the shell and send “reset” to the VM. Don’t ask me why/how but I can then start MacOS with clean graphics.

  7. It looks like the resolution woes on 5.2 can be solved like so: After following all of the instructions as written and you’re sitting at the Clover screen ready to boot the installer, just reset your VM (not stop/start). This seems to fix the screen resolution for Clover. (You don’t need to fiddle with the machine: version). It seems like the chosen resolution only works after a reset. You’d have to do this every time you started (not restarted) the VM to avoid the off-centre boot logo and scrambled progress bar.

  8. I`am using Proxmox 5.2-3 and tried to install High Sierra. Clover starts and i can select the install medium (sierra) but after selecting it freezes at the apple logo. When I used verbose logging it freezes after End Random seed ************ without any error.
    Can anyone help me?

  9. Hello, I followed your guide (twice) and did all steps including the custom OVMF package, and even re-downloading the MacOS installer, but am getting stuck at the initial booting of the installer from Clover. Booting in verbose mode, I see it gets to “AppleSMBusPCI::start failed to get acpi path for provider” and then it restarts and goes back to Clover. Any ideas? I’m on the latest version of Proxmox (5.2-2).

  10. SCRAMBLED SREEN SOLUTION:
    For those who have a really hard time getting to installer because of scrambled screen and non-persistent boot settings (because it resets after you stop the VM). Just modify clover config and set it to 800×600 and NO NEED to mess with bios.

    1. If the settings don’t persist then you are missing an EFI disk. You do need to reset the VM when Clover boots for the resolution to be applied though (instructions in the post)

      1. I have a Kaby Lake i7 and setting iMac18,3 passing cpu as host just gives me a black screen. Any tips to get it working?

        1. No, I’m sorry I was to quick to judge…
          I thought it was working, but in fact I was editing the wrong config… *stupid*

  11. I don’t know about Mojave but I just retested qemu with my IGD pass through and high sierra 10.13.6 and I can get cpu IvyBridge working with 4 cpus on q35.

    Here is the relavent part of command line for qemu:
    -cpu IvyBridge,+apic,+pclmulqdq,+ssse3,+popcnt,+pclmulqdq,+avx2,+invpcid,+ss,+aes,+sse4.1,+sse4.2,+xsave,+xsaveopt,+avx,+fma,+rdtscp,+pcid,+abm,+movbe,+f16c,+rdrand,+fsgsbase,+tsc-adjust,+smep,+bmi2,+erms,+invpcid,+arat,+bmi1,+kvm-pv-unhalt,+kvmclock,+kvm-asyncpf,+kvm-steal-time,+kvm-pv-eoi,+kvmclock-stable-bit,+invtsc,vmware-cpuid-freq=on,kvm=on,vendor=GenuineIntel -smp cpus=4

    1. Hey man, I’ve been trying to get my Kaby Lake IGPU passthrough to work for days. Can you share your VM conf and your Clover config.plist? Maybe it will help me out.

    1. Hit space at the Clover prompt and you can choose Verbose boot mode to see where it fails.

      Which version of Proxmox are you running?

      1. Here are the last couple of lines from the verbose output.

        Start LoadRAMDisk
        End LoadRAMDisk
        Start FinalizeBootStruct
        Start RandomSeed
        End RandomSeed
        +++++++++++++++++++++++++++++++++++++++++++++

        I just updated my proxmox install before trying this so I’m on the latest 5.2

        1. Sometimes the host has to be rebooted for a new QEMU version to be available, which might be the reason why it didn’t like your requested “machine” version.

          Make sure the patched UEFI firmware package is still installed and didn’t get overwritten during the upgrade.

  12. Ok, I decided to trash everything and start over. I got the installer to load and installed the system. However, now I’m stuck in a loop of choosing my region, keyboard and network settings. After entering them, the system reboots and asks me these things all over again.

    1. Normally when it reboots during early install it should automatically select “install macOS from ‘your hard disk'” at the Clover boot menu, which continues the installation for you. If it wrongly picked the DVD instead then it might end up starting over.

      1. I found the problem. Issue with my network adapter. I got the system to work. However now I have a new problem. While trying to make the clover install permanent, I get permission denied on the dd command. dd: /dev/disk2s1: Permission denied

  13. First of all thank you for the guide, got 10.13.6 up and running easily.

    Any chance you have iMessage working? I seem to have problems with the ethernet not being BuildIn which causes iMessage to not work.

    Also do you have a solution to the disk showing as external instead of internal? The usual kext patch does not seem to work.

      1. For anyone wondering this, I found a solution:
        1. Download DPCIManager: http://dpcimanager.sourceforge.net/
        2. Open DPCIManager in your VM
        3. Click the eye to the left of the Ethernet adapter in Status
        4. Copy the string without any of the XML around it.
        5. Paste that string into CloverConfigurator -> Devices -> Properties
        6. Reboot
        7. ???
        8. Profit, your Ethernet is now buildin and you can login to iMessage

  14. I had trouble to get the High Sierra Boot available in Clover but it turned out that the previously 1 CPU core was the issue. I set to 4 and it worked.

    1. Yes, that’s normal for a system with no hardware video acceleration. Try disabling hardware acceleration in the Chrome settings page (there is also a command line switch which achieves that).

  15. i disable acceleration, now i see all screen, but still lagg, I would like to use Chrome as the main browser, but now probably have to give preference to Safari (

  16. I’ve done everything over and over again, But no matter what right after I boot into the installer I get a frozen cursor in the top left corner.

    1. Sounds like there’s a problem with the tablet, especially if you can still use the keyboard to navigate the menus. Double check that the tablet is enabled for the pointer on Proxmox’s settings tab, and that you didn’t accidentally enter the wrong port number when you added the USB keyboard to pve-q35.cfg

        1. That should be fine. Are you using the default No VNC mode web interface on the console tab? Are you able to do anything with the keyboard or is the VM maybe locked up?

          Maybe post your VM config to pastebin and link it here.

  17. Hello.
    I followed your guide successfully.
    However, I am doing something specific, to be honest I am trying to dual boot inside the Proxmox VM.
    So I started another install from scratch, expect I started the first VM with Windows 10, GPU is passing through relatively well (…Nvidia Code 43…).
    My current problem is with Clover, it can’t display my High Sierra ISO.

    Proxmox VM ID 100:
    args: -device isa-applesmc,osk=”NothingToSeeHere” -smbios type=2 -cpu host,kvm=off,hv_relaxed,hv_spinlocks=0x1fff,hv_vapic,hv_time,hv_vendor_id=whatever,vendor=GenuineIntel,+invtsc,vmware-cpuid-freq=on
    balloon: 0
    bios: ovmf
    boot: c
    bootdisk: ide2
    cores: 4
    cpu: host
    efidisk0: sdc1:100/vm-100-disk-2.qcow2,size=128K
    hostpci0: 01:00,pcie=1,x-vga=on,romfile=GP104.rom // NVIDIA GTX 1070 8GB Asus STRIX Gaming
    ide0: local:iso/HighSierra.iso,cache=unsafe
    scsi0: sdc1:100/vm-100-disk-1.qcow2,size=256G // VirtIO SCSI Windows main drive
    ide2: local:iso/clover-r4428-amd64.iso,cache=unsafe
    machine: pc-q35-2.11
    memory: 16384
    name: MrBig
    net0: e1000-82545em=A6:01:6D:25:22:34,bridge=vmbr0
    numa: 0
    ostype: other
    sata0: sdd1:100/vm-100-disk-1.qcow2,size=128G // the hard drives for MacOS High Sierra
    scsihw: virtio-scsi-pci
    smbios1: uuid=d182ece0-ce90-4be1-b64d-1fcb73a396f2
    sockets: 1
    usb0: host=1b1c:1b33 // Corsair KeyBoard
    usb1: host=1532:003e // Razer Gaming Mouse
    usb2: host=046d:0a5b // Logitech Headset
    vga: std

    // = Comment is starting

    Under Windows the 3 usb devices are recognised same for the GPU.
    Clover ISO is booting but I only see 4 Windows drives logos, tried to boot each of them, the first one is for Windows 10, the second is the EFI drive, and the two remaining won’t boot, black screen with a grey square in the middle.

    Many thanks for anyone which can help 🙂

  18. Hey Nicholas, awesome stuff, thanks for all your obvious hard work making this go.

    I’m very curious how your setup looks, do you have a post discussing how you’re using a mac VM as your “daily driver” as referenced in the USB passthrough section?

    I’m also very interested in knowing if you’ve had any luck with getting SPICE going on the macOS guests. I’d like to be able to copy/paste between my host and guests.

  19. Hey Nicholas, this is very useful for me, thanks a lot

    I’ve installed Sierra on my Hetzner Server, and I changed CPU from Penryn to host(i7 7700), it worked.

    Is there any way to upgrade the VGA? I’ve set the VGA memory 512M in proxmox, but in Mac it’s only 8MB. I can’t passthough GPU to Mac because i run Plex in other VM.

    BTW, I want to translate this artical to Chinese,is that OK to you? Thanks

    1. You can increase the screen resolution, but there is no point in increasing the video memory – there is no acceleration available so it can’t use the extra memory for anything. You need a real video card to get good video performance.

      Sure, you can translate it!

  20. Hi all,

    I’m currently trying to install macOS High Sierra on a Proxmox enviroment version 5.4. But for any reason, I don’t can boot the clover image, even if I will set IDE 2 as boot device by following the steps above.

    I always will end up in the UEFI shell… Any suggestions?

    Cheers,
    Tim

  21. Hey Nick,

    I am running Proxmox 5.4-3, I have followed your step twice and I am stuck at the same spot. After installing the OS and the VM reboot back to Clover boot installation screen.

    The only thing that is different from your screen shot is during the installation for the MacOS, two drives appears sata0 and ide0. The ide0 is locked and i am able to install on the sata0.

    Here is my setup:
    args: -device isa-applesmc,osk=”******” -smbios type=2 -cpu Penryn,kvm=on,vendor=GenuineIntel,+$
    balloon: 0
    bios: ovmf
    boot: cd
    bootdisk: ide2
    cores: 4
    cpu: Penryn
    efidisk0: pveit_nas-460-003:112/vm-112-disk-1.raw,size=128K
    ide0: pveit_nas-460-003:iso/Mojave-installer.iso,cache=unsafe
    ide2: pveit_nas-460-003:iso/clover-r4920.iso,cache=unsafe
    machine: q35
    memory: 8192
    name: mojave
    net0: vmxnet3=32:5A:12:33:DB:5A,bridge=vmbr0,firewall=1
    numa: 0
    ostype: other
    sata0: pveit_nas-460-003:112/vm-112-disk-0.raw,cache=unsafe,size=100G
    smbios1: uuid=8e61346b-2cf9-4f6b-b041-184060a31556
    sockets: 1
    vga: std
    vmgenid: 528eb22c-0f77-404e-a361-f140de70e559

    Any ideas on how to stop the loop?

    1. At the first reboot during installation, enter UEFI setup and pick a different drive to boot from in the boot manager. Somehow this triggers Clover to detect the hard drive as a boot option, but this only happens to some people.

    1. Hm do you have cache=unsafe on the line for the High Sierra installer? The other thing to check is make sure the ISO is not stored on a read only storage, since it’ll be modified during boot.

      These instructions are really out of date and I’d suggest updating to my latest OpenCore/Catalina tutorial, unless you absolutely have to have High Sierra. (You can also try using those newer instructions to install High Sierra, they only need a little adaptation)

      1. Thanks for the reply, I have to use High Sierra because the host’s CPU is an older Xeon without SSE4.2.

        ide0: local:iso/MacOS High Sierra 10.13.1.iso,cache=unsafe,media=cdrom
        ide2: local:iso/clover-r4428-amd64.iso,cache=unsafe

        I’ll try your Catalina tutorial with High Sierra, thanks.

Leave a Reply to Marien Spek Cancel reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.